Switchem Support Center

Contact Us

Can I run Switchem on OS X 10.10 Yosemite or older versions?

Switchem requires MacOS 10.11 El Capitan or 10.12 Sierra and around 30 MB of free space to operate. Due to the latest technologies and frameworks exclusive to El Capitan and Sierra that Switchem has been built upon, unfortunately, we will not be considering supporting Switchem on either of these older OS X versions.

Powered by HelpSite